New posts no longer rank that well straight after indexing

Joined
Nov 15, 2018
Messages
20
Likes
14
Degree
0
Hi guys,

I have a site that you could say is in authority mode where most new content (unless it's something really competitive) will index on the 1st, 2nd or 3rd page of Google. But recently I noticed that my site kind of lost its power for new posts and they don't rank that well straight away after indexing anymore.

https://www.seroundtable.com/google-not-indexing-new-content-again-test-28087.html I can see some folks reporting a similar thing in the comments.

Is anyone experiencing a similar issue as well? That link I added above confirms there is an issue but I'd like to get more insight from BuSo people.
 
Joined
Dec 31, 2016
Messages
525
Likes
354
Degree
2
Yes, as I wrote in another thread, the Google index seems very sluggish and "stuck" outside the first page (Rankbrain?).
 

Ryuzaki

女性以上のお金
Staff member
BuSo Pro
Digital Strategist
Joined
Sep 3, 2014
Messages
3,578
Likes
6,719
Degree
7
Even before now this would happen randomly. I'm convinced that they apply their Rank Transition algo to newly indexed posts as well as to when applying new backlinks. The Rank Transition thing is when you get a backlink and you can get a delayed reaction and even a negative bounce for up to 90 days. I've seen lots of examples on my own sites of posting an article that should have slammed to the top and had to wait anywhere from 60-90 days. It sucks and drives me nuts. Best to keep publishing than stress over it and trying to "fix it" makes it worse (take longer).